Labs for ROW Geometry & Plans

LAB 15 - Parcel Descriptions

LAB 15 - Parcel Descriptions

The InRoads Report Browser allows the user to view reports using a reporting utility based on the eXtensible
Markup Language or more commonly referred to as XML. Like the HTML language used for web
development, XML reporting is based on tags and attributes which delineate elements of data. Formatting of
XML data is accomplished through the use of XSL, or style sheets and displays in a web browser page.

Chapter Objectives:

1.

4.

Create a parcel legal description

Select the Tools > XML Reports menu item to check the available menu items.

-

Select Legal Description

Bentley InRoads XM Edition o =&
] y
<Uiramed> TES 8N BX 5@
Fie Suface Gi Drainage Evaluation Modeler Drafting] Tools
[~ By % | hIEB L«ﬁ L= lf.‘}g b':-, XML Reports Iﬁa Geometry...
M ¢ View XML Repors... £ Station Base...
( ame Trackin | B Sta o
| =2, Geometry Projects r ng . jon Offset
#-[= Default = Named Symbology Manager... é gteiran:e'“
#-f= 12345ROW_ROW Preference Manager... = et .
- =] TRAINRow_ROW Style Manager... g ::ga&:kmm_.
- Cogo Buffer : - Map
T f C Cgenterline S, Hghlght Al Penci ) Intersecting Akgnment Stations...
41/ Northerly ROW A Highight Al Ik & Sufaces...
7] 2 [1"‘ Convert Pencil to Ink... a Surface Check.
i J Dak Street Iy

<D> the Filter button and add Summit BP Lot 1 as a selected alignment.

P

ot Geometry Selection Filter
Name: Included v| " oK
o A=
Descrption: | included z) [ cowel |
Style: -| -
fckided J | Preferences...
Available: _Selected: __Heb
Name Description i A Name Description Style
C_Centerdine Reference Line A Summit BP ... Lot 4 of Summit Bu... RW_OWN_Pr...
Northerdy ROW R
Oak Street Al <- Swap ->
ROW Limits South 2 R =
ROW Limits South 3 R
S.H. 83 South ROW Proposed RW at C_.A| || [ None
Summit BP Lot 1 Summit Business P._R
Summit BP Lot 2 Lot 2 of Summit Bu...R
Summit BP Lot 3 Lot 3 of Summit Bu...R
Summit BP Lot 5 Lot 5 of Summit Bu...A
Summit BP Lot 1 Acquire  RW Acquistion A
Summit BP Lot 1 Remaind... Parcel Remainder A ~ |
4 m 3

<D> OK.

5. <D> Closed Alignments.
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6. <D> Apply.

7. Inthe Bentley InRoads Report Browser, select File > Save As and enter
C:\Projects\12345\ROW_Survey\InRoads\Reports\SBP Lot 1.xml

8. <D> Save

An XML file and a report is created with format and display from an InRoads default style

sheet.

File Tools Help

@] Bentley InRoads Report Browser - C:\Users\PCALLA~1\AppData\Local\ Temp\RPT1059.xml

Workspace-COOT_XM\
Bridge -

bal\InRoads' XM

] Images

Intersecting Aignment Stations

LegalDescription

é;'] Horizortal Aignment LegalDescription xs|

Af] Honzortal AhgnmentLegal Description Reference xs!

A | A Legally ion R weASCl xsl

Property Description

Report Created: 9/14/2009
Time: 3:26pm

Project: TRAINRow_ROW
Description: training class

C:\Survey Training Matenial\Part2112345

File Name: \pow_SunveylinRoads\Geometry\ TRAINRaw_ROW.alg

Last
Revised: Pcallahan 9/14/2009 3:08:32 PM

Input Grid
Factor:

Note: Allungs in this report are in feet unless specified

1.00000000 otherwise

by
Aj] ParcellayoutFromReference xsl
A{] PropestyDescription xsl

Aj] PropertyDescriptionExtended xs!
A]) ProperyDescriptionExtended 2 xsl
A{] PropestyDescriptionLongNames xsi
Al RghtONWay Takes xs!

Light RailManufacturing

=) MapCheck

) Obsolete

RoadwayDesign

-] Schemas -

Alignment Name: Summit BF Lot 1
Alignment Description: Summit Business Park Lot 1

Beginning at a point thence S 0°36'33" E a distance of 384 94 feet thence
S 89°2356" W a distance of 98.12 feet thence N 81°4943" W a distance
of 64.63 feet thence N 73703217 W a distance of 129.79 feet thence N 0°
3421" W a distance of 416.91 feet thence S 74°46'11" E a distance of
296.74 feet and the POINT OF BEGINNING.

9. <D> on the various report styles (*.xsl) displayed in the left panel and notice the change to
the format and contents of the displayed report.

10. In the Report display, select Tools > Format Options

Format Options =l
Mode Precision Format cl
Northing/Easting: ID' 12 = I e
A —IHeb

Elevation: |D.12 'l
Angular: Degrees ~l o =] |ddd"mmiss” »| I Include Angular Suffic
Slope: foazz <] [s0% |
Use Altemate Slope if Slope Exceeds: 0.000%

Atemate Slope: o =] [201 -
Linear: m
Station: jo12 | fssessss |
Acres/Hectares: 01234 ~
Area Units: m
Cubic Units: 0.1 «| ¥ Convert to Cubic Yards
Direction: [Bearngs ~[o | [ddd"mmsss" ~|
Face: Right Face '1
Vertical Observation: |7angh v ]
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11. <D> Acres/Hectares: Set to 5 decimal places - the report updates.

The above described parcel contains 4 2.69878 acres|(117559.0 sq. ft.)

12. Change any of the fields in the Format Options dialog and notice the report interactively

updates.
13. In the Report display, select File > Save As...

Save As:

Path: C:\Projects\12345\ROW_Survey\InRoads\Reports

File Name: SBP Lot 1.xml

14. <D> Save
@) Save As
Savein: | Reports j EF '
o Name Date modif... Type Size Tags
%
e = SBP Lots 1-4.xml
Recent Places
Desktop
Iﬁ"‘-l
CDOLI; User
Computer
AL
-—
Network
File name: [SBP Lot 1.2aml j Save I
Saveastype: XML File ("ml) | Cancel
Help

Reports can also be recalled for reformatting, etc.
15. Select File > Open from the report browser.

16. Open the SBP Lots 1-4.xml file from the folder:
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C:\Projects\12345\ROW_Survey\InRoads\Reports

~| «®erE-

Size Tags

=

Look n: | |}, Reports
== Name’ Date modif... Type
= ,
|2 SBP Lot 1.xml
Recent Places =
¥ = SBP Lots 1-4.xml
Desktop
U
CDOT_User
A
Computer
A«
- - _
Network
File name: [SBP Lots 1-4xml
Files of type: |XML Data (*aml)

it

17. <D> on the category Geometry and style sheet Area.xsl

File Tools Help

[C:\Workspace \Worspace COOT_XM\Standards-Global InRoads )M

[ Geomety A
Aj] Aeaxal

Aj] Controlling Data xsl

AJ) Horzortal Algrment AndEvents xsl

A]) HorzortalAlgrmentCurve SetReview xsl

Al] HorizontalAlgnment Data xsl

Al HorzortalAlgrmentLengths xs

Aj) HorzontalAlgnment Review xsl

.Eg HorizontalAbgnment ReviewASCll xsl
et # n
A

g sl

Af And ligr R e
Aj] HorizontalElements Table xsl

Aj) HonzortalBementsXYZ xsd

A) HorizontalEvents xsl

Aj) Horzontalinterpolated Slews xal

A]] LitCoordnates xs!

Al] LsCoordnates Staton sl

Al] ProfieStationBevation xel

Aj) ProfieStationBevationASCl xsl
A]) ProjectAbgrment Listing xsl

Al] ProjectAbgnment Listing Details xal
Aj) SettngQOut Table xsi

Aj) SewDagram xel

Aj] SewDiagramLegacyFormat xal

Aj) Traversexs!

Af] TraverseCurve ASCllxsl

Af) TraverseCurve ASCI2 sl

Aj) TraverseCurveASCIIIxsl

Al] TraversePoints xsl

Aj] Vestical Aigrment IPercentGrade xsl

Area Report

Report Created: 9/14/2009
Time: 4:17pm

Project: 12345_SummitBP.alg
Description: Lab 18
C:\Projects\12345

File Name: \o6u” SurveyiinRoads\Geometry\12345_SummitBP. alg

Rovieas! jemy 511772007 5:48:24 PM

Input Grid

Factor: | 000000

Note: Allunits in this report are in feet unless

specified otherwise.

Aj) Vesscal AgnmentAndEvents xsl
Af] Vertical Abgrment Review xsl -

Area  Perimeter

Lot Anoial ooy M

Summit
BP Lot 2162425 496424 202898
4

Summit
BP Lot 1176327 270047  1391.22
1

Summit

BP Lot 1033543 237269 134976
2

Summit

BP Lot 1064335 244338  1503.86
3

Note: Lot areas and perimeter distances are reported.
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18. In the category Geometry, access style sheet List Coordinates

-Q"Ben'ﬂej InRoads Report Browser - C:\Projects\12345\ROW_Survey\InRoads\Reports\SBP Lots 1-4.xml
File  Tools Help

IE:\F‘rogram Files'workspace-COOTAStand 1’\]
] Dridee T List Coordinates Report 1
=1 coor B ‘
=1 Clearance Report Created: 5/18/2007 E
I_7] Custarn Time: %:53am |
" DataCollection |
= =
. Ge”;‘;iyxsl Project: 12345_SummitBP.alg

]

Description: Lab 18
C:\Projectsi12345

;\:_ ControlLineD ata.xsl

H ‘;\__ HorizontaldlignmentindE vents.

H ‘;\__ HorizontaldlignmentCurveS etRe
A
A

izontald reietfle File Name: \poyy” SuveylinRoads\Geometry\12345_ SummitBP.alg
HorizontaldlignmentF eview, xsl
Harizantalndvericallignmentl Last jerry 6/17/2007 5:48:24 PM
; ol Revised:
E ListCoordinates. xsl Input Grid 1000000 Hote: All units in this report are in feet unless
- Factor: specified otherwize.
H ‘;\__ ProjectilignmentListing. =s!
H ‘;\__ SettingOutT able. xzl . : %
] SlewDiagram.se Alignment Name: Summit BP Lot 4
H ‘;\__ Superelevationdlignment. xs| Point . ) p
& SuperelevationData xsl Narie Type MNorthing  Easting Elevation Style
i ‘;\__ WerticaldlignmentandE vents xzl e e
A7 VerticaldignmentReview.ssl POB 1556287.88 3278721 92 0.00 RW_OWN_Prop-
1 Images ' . i Line_exist
1”7 LegalDescription ke 3
[ Schemas (v PC 1555768.38 3278999.07 g, LIRS Yop
Al 1l | B3 e el [
2 - L= ]
The report is redisplayed to display alignment coordinates.
19. While viewing the xml report, <R> on the screen - a fly-out menu appears.
20. <D> on Export to Microsoft Excel
@ Bentley InRoads Report Browser - C:\Users\PCALLA~1\AppData\Local\Temp\RPTEBDAxml =R o>
File Tools Help
[c:Worlkspace\Workspace-CDOT_XM\Standards-Global\InRoads X1 e -
=) Geometry = - ates Report
Al Aeaxsl
4] ControlineDiata xs| d: 9/14/2009
&) Hodzortalign AndEvents xel Save Background As... -06pm

\~AJ] Horizontal MignmentCurve Set Review xsl Set as Background
4] Horizontal Mignment Data xs!

A Horizontal MignmentLengths xs!
@ Horizortal Aignmert Review xs| Select All
Al HorzontalAignmertReviewASClIxs

Copy Background

Naterial\Part2112345

Paste

-—~Aj] Horizontal Mignment Supeselevation Review xsl
4] Horizontal AndVestical Aignment Review xs!
(4] HorizontalBements Table xsl

i~4Ad] HorizortalBlementsXYZ xsl

A HorzortalEventsxs!

+—~Aj] Horizontalinterpolated Slews xsl
A ListCoordinates xs!

4] ListCoordinates Station xsl

\~Ad] ProfileStation Elevation xsl

\~AJ] ProfileStation ElevationASCI|xsl
+—Aj] Project AignmentListing sl

A Projsct Aignment Listing Detais xs|
(Al SettingOut Table xs!

[~ Ad] SlewDiagram xsl

\~Aj] SlewDiagramlegacyFomat xsl
—Aj] Traversexs!

4] TraverseCurveASCIl sl

i) TraverseCurveASCILZ xsl

~AJ TraverseCurveASCII3xsl

+—Aj] TraversePaints xsl

A Vetical Mignment 3PercentGrads xs|
(4] Vetical Alignment AndEvents xsl
(Al Vedical AignmentReview xsl

m

Create Shortcut

ads\Geometry\12345ROW_SummitBP .al

§:05:16 PM

Add to Favonites...

- Note: Allunits in this report are in feet unles
View Source specified otherwise
Encoding
Print...
Print Preview... ling  Elevation Style
Refresh S e = >

RW_Property-

Append to Existing PDF o-04 0.00 Bndry-Line_ex
C rt to Adobe PDF -

ervertfe Adene ha13 000 RW_Property
Customize Menu Bndry-Line_ex
Export to Microsoft Excel 598 0.00 g'hg_l’?per‘ty-
Fill Forms ndry-Line_ex
RoboForm Toolbar 13.23 0.00

Save Forms

Properties

42.03 0.00 RW_Property- -
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Alel ¢ ] b | E | F

Excel will launch a New Web Query. Check on the coordiantes section and import the results.

—1

1 |Point Type Northing Easting Elevation Style

2 |Name

3 POB 1556037.836 3279640.04 0 RW_Property-Bndry-Line_ex
4 PI 1555652.96 3279644.13 0 RW_Property-Bndry-Line_ex
5 PC  1555651.93 3279545.98 0 RW_Property-Bndry-Line_ex
6 PI 1555651.28 3279513.23 0

7 cc 1555851.89 3279542.03 0 RW_Property-Bndry-Line_ex
8 PT  1555661.12 3279481.99 0 RW_Property-Bndry-Line_ex
9 Pl 1555698.89 3279357.98 0 RW_Property-Bndry-Line_ex
10 PI 1556115.81 3279353.81 0 RW_Property-Bndry-Line_ex
11 POE 1556037.86 3279640.04 0 RW_Property-Bndry-Line_ex
1147< » M| Sheetl  Sheet2 ~ Sheetd ~¥J £ I m I |

Note: The output to Excel will only contain data from individual alignments based on the
location in the xml report the fly-out menu was activated.

To view the source information the xml report was generated from:

21. In the Report browser, select Raw-xml.xsl in the left panel

2] Bentley InRoads Report Browser - C\Users\PCALLA~1\AppData\Local\Temp\RPT1442 xml
File Tools Help

===

|C:\Work5pac:e\Workspace-C DOT_XM\5t

1 MapCheck -
] Obsolete

"] RoadwayDesign

1 Schemas

] Stakeout

[T StationOffset

1 Superelevation

1 Surfaces

productVersion="08.09.02.16"

Description Report">

= HN lastRevisedBy="pcallahan">

m

=?xml version="1.0" encoding="iso-8859-1" ?>
- <InRoads productName="Bentley InRoads XM Edition"

outputGridScaleFactor="1.00000000"
inputGridScaleFactor="1.00000000" linearUnits="Imperial"
angularUnits="Degrees" gauge="4.708333"
equilibriumConstant="4.650000" commandName="Legal

- <GeometryProject name="12345_SummitBP" description="Lab

] Tabling 18" file="C:\Survey Training Material\Part2\12345

7 TemplateLibrary \ROW__Survey\lnRoads\Geometry\ 12345ROW_SummitBP.alg"
] Tumouts lastRevisedDate="9/14/2009 8:05:16 PM"

- <HorizontalAlignment name="Summit BP Lot 1"

3 cdotformat xsl style="RW_Property-Bndry-Line_ex" description="Lot 1

H Frct e of Summit Business Park" curvatureDefinition="arc"
lastRevisedDate="3/5/2006 9:46:45 PM"

lastRevisedBy="Brys" closingDistance="0.004754" -

m

- 4 I

What you see are the xml tags and attributes which define the report contents. Formatting
of this data for display is accomplished through the use of xsl, or style sheets. Style sheets
can be developed by the user for customized reports or formats.

Other formats:
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In the category DataCollection access style sheet
ListCoordinatesSDR32InternationalFoot

2] Bentley InRoads Report Browser - C\Users\PCALLA~1\AppData\Local\Temp\RPT2266.xml = | 5]
File Tools Help
|C:"-.‘.‘\i'orkspace"-.‘.‘\i'orkspace-cDOT_XM"-.Standan:Is-Global"- -
OONMSDR33 V04-04.xx 122211
----- E HorizontalElements SDR33Metric xs| - OENM1.00000000000000
""" 4] HorizontalElementsSDR33USSurveyFoot s 13NM3/14/2009 Point Listing for SDR33
""" 4] HorizontalOff Aligrment Points sl 13NMProject Name: 12345 SummitBP
----- E HorizontalOnAlignment Points xs| 13T514-SEP-2009 -
""" Al ListCoordinatesGeodimeterFomat s 08KI 1556037.855344003279640. 03934400
""" 4] ListCoordinatesLeica 16 3 08KI 1555652.959017003279644. 12952200
""" Al UstCoordinatesLeicadxsl 08KI 1555651.923544003279545. 98172800
""" Al ListCoordinatesSDR33IntemationaiFoot xS 08KI 1555851.890535003279542 . 03178200
""" 4] ListCoordinatesSDR33Metric s 08KI 1555661.116530003279481 . 98780800
""" Al ListCoordinatesSDR33USSurveyFoot s 08KI 1555698.887083003279357. 98247600
""" Al SDMSFomat xsl 08KI 1556115.806242003279353. 81380500
""" Af) SmpleListCoordinates xsl 08KI 1556037.860302003279640. 03563800
----- E StakeoutSDR20xsl
----- E StakeoutSDR33xsl
----- E StakeoutSMI sl
----- E StationEquationsLeica 16 xsl
----- E StationEquationsLeicad xs|
----- Aj| TDSCR5Fomat xs| 2 e
] Tl 3 4 Tl b

Experiment with other style sheets such as HorizontalElementsSDR33 as well as other style

sheets in the Geometry category.
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