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LAB 5 - Horizontal Alignments

Although there are multiple methods for creating horizontal geometry in InRoads, this lab will concentrate on 
the using the horizontal curve set commands and Importing geometry from graphics.  Additional methods 
covered in the Geometry for ROW course include joining cogo points together and the traversing commands.

Another aspect of this lab is to learn how to modify or create new geometry from geometry features that exist 
in a geometry project.  An example of this would be to create parallel/offset alignment such as a centerline to 
represent the edge of road or other feature that parallels the centerline.

Chapter Objectives:

 Create a new geometry.

 Create alignment tangents.

 Define alignment curves.

 Learn how to define and modify alignment stationing.

 Annotate an alignment.

 Create a horizontal alignment form graphics.

 Modify an existing alignment.

 Create parallel horizontal alignments.

The following files are used in this lab:

 C:\Projects\12345\Design\Drawings\Reference_Files\12345DES_Model.dgn

 C:\Projects\12345\ROW_Survey\InRoads\InRoads\12345SURV_Fieldbook.alg

 C:\Projects\12345\Design\InRoads\12345DES_Design.alg

A predefined workflow for creating geometry is not dictated by InRoads.  However, a typical workflow might 
be:

1. Create or open an existing geometry project

2. Create horizontal alignments (or Cogo points)

3. Assign stationing for alignments

4. Define alignment station equations, if any

5. Define alignment key-points (unique points of interest)

6. Review alignments

7. View created alignments

8. Display stationing for alignments

9. Annotate created alignments

Before continuing with this lab, delete all visible graphics in your MicroStation file using the 
element selection tool or a fence. Note that you are deleting the graphical display of data, not 
the data itself. The graphics could be redisplayed using the InRoads display commands shown 
in previous sections.
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Note: The screened topography and the training guides are either locked graphics or in an 
attached reference file, you will not be able to delete these graphics and will use them 
for orientation.

Lab 5.1 - Review Geometry from Survey

Section Objectives:

♦ Understand the difference between Named and Unnamed cogo points and how to apply 
cogo point names

1. Start InRoads using your desktop icon and opening the file 12345DES_Model.dgn from 
the C:\Projects\12345\Design\Drawings\Reference_Files\ directory.

2. Open up the InRoads Options dialog box from the menu bar under Tools > Options and 
review the settings in the Geometry tab.

Note: For descriptions of each of the items in the Geometry tab, refer to the Practical 
Guide for Using InRoads.

3. Load the geometry project 12345DES_Design.alg from the folder 
C:\Projects\12345\Design\InRoads\.
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Alignment key-points (PC, PI, PT, CC, etc) exist in one of three states:

♦ Unnamed

♦ Named

♦ Cogo Points

4. Review the horizontal alignment and notice that many points on the alignment are not 
named.
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Note: If Point Name During Edits is set to Named on the Geometry tab of the Options 
dialog box, alignment key-points are generated with a name based on the next available 
ID as specified in the Seed Point Name field.   The specified seed point name can be 
alpha, numeric, or alphanumeric characters. The assigned name is also reserved in the 
Cogo buffer.  However the point is not written to the Cogo Buffer automatically.

5. To create point names for all alignment key points and add them to the Cogo Buffer, select 
Geometry > Horizontal Curve Set > Events.

6. In the Horizontal Events dialog box, toggle on Alignment Point to Cogo in the Add As 
section.

7. Key in 200 for the Seed Name:, Proposed Alignment for Description:, and select 
ALG_PRO for the Style:.

8. Click Apply.
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A Results dialog box will appear with the new point name and the associated coordinates of 
the point.  All alignment key points that were not previously assigned a name are written to 
the Cogo buffer beginning with the ID number of 200.

Note: The command Geometry > Utilities > Assign Names can also be used to add, 
delete, or rename geometry points.

9. Close the Results and Horizontal Events dialog boxes.

Lab 5.2 - Create New Geometry

Section Objectives:

♦ Learn how to create a geometry project and place holders for horizontal geometry data.

Next we will create a new geometry project and a placeholder for horizontal alignment data.

1. From the pull-down menu File > New.

 

2. <D> the Geometry tab.

3. For the Type, choose Geometry Project.

4. In the Name field, key in 12345_Geometry Training.
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5. In the Description field, key in Geometry Training class.

Note: The lower portion of the New dialog displays geometry projects that are currently 
loaded into memory.

6. <D> Apply (Do not Close the New dialog box yet).

Note: InRoads created the geometry project and made it the active geometry project. Any 
horizontal alignments created will be placed in the active geometry project.

7. Verify that the new geometry project was created.

Note: This creates the geometry project where all new alignment data will be stored. At 
this point, it is held in RAM (Random Access Memory). When saved to the hard 
drive, the default extension will be *.alg, as was assigned to previous geometry 
projects.
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8. Use the following data to create a place holder for horizontal geometry data.

♦ Type:  Horizontal Alignment
♦ Name:  Design Alt 1
♦ Description:  Alignment by PI method
♦ Style:  ALG_PRO
♦ Curve Definition:  ARC

9. <D> the Apply then Close buttons.

10. Verify the horizontal alignment is created in the active geometry project.

11. From the MicroStation pull-down menu select Utilities > Saved Views.
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12. From the Saved Views dialog <D> saved view name SH 86 ALT 1.

13. <D> the Apply button.

Points A-M represent the required location of alignment PI’s. 

Horizontal curve set commands will be used to create the horizontal alignment. The steps 
will be used to construct the tangents, then insert curves between the tangents once 
constructed.

Note: The following labs will step you through creating an alignment using the Horizontal 
Curve Set, or PI method. While these exercises are based on a roadway alignment, the 
tools and logic apply to any new alignment whether it is for drainage, utilities, 
pavement marking, bridge geometry, parcels, or any other purpose. 

Note: For orientation screened graphics and curve radius values are shown for the alignment 
that will be created.
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Lab 5.3 - Create Alignment Tangents

Section Objectives:

♦ Learn how to create horizontal alignments from PI to PI. 

The first toolbox that we will use is the Horizontal Curve Set commands.  These commands 
present an easy way to create alignments. They consist of five primary commands described 
below and may be accessed from a toolbar (shown) or from the pull-down menu under 
Geometry > Horizontal Curve Set.

Add PI is used to create a PI that begins a new alignment, or to add a PI onto either end of an 
existing alignment thereby extending it.

Insert PI is used to add a PI to an existing alignment between two existing PIs.

Move PI is used to change the location of a PI previously established.

Delete PI is used to remove a PI from an existing alignment. For removing more than one PI, 
you must choose and Accept each one individually. To remove all PIs associated with an 
alignment, but leave the alignment name, right-click on the alignment name in the Explorer 
menu and choose Empty.

Define Curve is used to either establish curves or to edit curves previously defined.

Stationing for establishing stationing or station equations along an alignment

Events are used to establish unique locations relative to an alignment, Cogo points, or the 
assignment of Cogo points along an alignments keypoints.

In this lab you will create an alignment using the Horizontal Curve Set, or PI method. First 
input the tangent sections of the alignment by selecting locations graphically. This is 
accomplished by <D> at the desired location. Once the tangents are in place, curves between 
these tangents will be defined.
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1. Before beginning, verify the proper alignment is Active. This is necessary as any geometry 
entered will be populated in the active alignment.

Design Alt 1 should be the active alignment. If not, several options exist to define it as the 
active alignment.

♦ Right-click <R> on the horizontal alignment name and select Set Active from the fly-
out menu.

♦ From the pull-down menu, select Geometry > Active Geometry and use the 
resulting dialog to set the active alignment.

2. To clear the MicroStation view turn Off the Reference Display for the 
12345SURV_Topo100Scale01.dgn in the References dialog box.

3. Select Geometry > Horizontal Curve Set > Add PI.  You are prompted in the 
MicroStation status bar to Identify Alignment End.
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4. <T> and <D> at point A (tentative or snap, and Data point). The alignment interactively 
displays as you move the cursor.

5. Continue to issue a series of points <T> and <D> through points B-M.

6. <R> (reset) when complete.

7. If the alignment created does not pass through points A-M, use the Insert, Move, or Delete 
PI commands from the Horizontal Curve Set tools to correct the locations.
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8. Review the new alignment using Geometry > Review Horizontal…

Following is a summary of the PI locations

Note: Results may vary based on the specific PI locations defined by the user.

The next lab teaches how to define the horizontal curves.

Lab 5.4 - Define Alignment Curves

Section Objectives:

♦ Learn how to add curves to horizontal alignments using various methods

♦ Learn how the Curve Calculator is useful in calculating an unknown curve radius

The Define Horizontal Curve Set command is used to create curves between alignment 
tangents or to revise existing curve definition. The Previous and Next buttons can used to step 
sequentially through the alignment. The Select button can be used to graphically identify an 
alignment location for editing.  As alignment components are selected, they highlight in the 
MicroStation view. 

PI NORTHING EASTING BEARING DISTANCE STA.
A  1,558,417.74  3,267,409.40 0+00.00
B  1,558,457.06  3,268,756.14  N 88°19'39.62" E  1,347.31' 13+47.30
C  1,558,469.66  3,270,669.73  N 89°37'21.60" E  1,913.63' 32+60.94
D  1,558,050.59  3,272,645.47  S 78°01'28.88" E  2,019.69' 52+80.63
E  1,556,982.55  3,276,540.43  S 74°39'56.80" E  4,038.75' 93+19.38
F  1,556,716.98  3,277,527.47  S 74°56'25.98" E  1,022.14' 103+41.51
G  1,555,931.76  3,280,408.64  S 74°45'18.96" E  2,986.25' 133+27.77
H  1,555,939.60  3,282,135.29  N 89°44'23.81" E  1,726.67' 150+54.44
I  1,555,699.32  3,283,343.64  S 78°45'12.06" E  1,232.01' 162+86.44
J  1,554,474.27  3,288,508.48  S 76°39'23.63" E  5,308.14' 215+94.58
K  1,553,821.34  3,290,431.45  S 71°14'44.01" E  2,030.79' 236+25.37
L  1,553,315.19  3,291,416.57  S 62°48'22.55" E  1,107.55' 247+32.92
M  1,553,346.54  3,293,367.43  N 89°04'46.05" E  1,951.11' 266+84.03
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1. Select Geometry > Horizontal Curve Set > Define Curve.  The first two tangents 
A-B and B-C highlight.

2. Key in Radius 1: 21120.

3. <D> the Apply button.  The curve is created and displays.

4. <D> the Next button.  Tangents B-C and C-D highlight.

5. Key in Radius 1: 3000.

6. <D> the Apply button.

7. Repeat steps 4-6 for the curves at locations:

D  Radius = 11,000.00
E   Radius = 3,000.00
F   Radius = 3,000.00
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For the first 5 curves, radii were input to define the curves. For the curve located at point G, the 
degree of curve is the known component (along with the external deflection angle). Use the 
Curve Calc…. button to solve the curve data.

8. <D> the Next button to define the curve at point G.

9. <D> the Curve Calc… button.

10. Set Compute: to Simple Curve.

11. Calculate based on a 5 degree 30 minute 17 second curve.

12. Key in 5 30 07 for the DOC: the field and verify that the Lock field is Checked On. 
(Verify the Radius option is unlocked and that only 2 fields shown below are locked).

13. <D> Compute.

Notice the changes that occur in the dialog.
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14. <D> OK. The Curve Calculator dialog will close and the calculated radius will be 
populated in the Radius 1 field in the parent dialog.

15. <D> Apply and the curve will be created.

The next curve (location H) will also be developed using the degree-of-curve. However a short-
cut will be used to generate the input for the Radius 1 field.
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16. <D> Next to select the tangents on either side of point H.

17. In the Radius 1: Field Key in D 2-23-14.

18. Press the keyboard <TAB> key to leave the field. The radius (2400.10) will compute for the 
selected location.

19. <D> Apply to form the curve.
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20. If time permits, complete the remainder of the curves as noted in the drawing and listed 
below:

I   Radius = 15,000.00
J   Radius =   5,000.00
K  Radius =  3,000.00
L   DOC =  3-34-52

21. Review the alignment data select Geometry > Review Horizontal.

Lab 5.5 - Alignment Stationing

Section Objectives:

♦ Understand how to change the assigned stationing of an alignment.

The default station value assigned to the start of a new alignment is 0+00. Redefine the 
beginning station to 100+00.00

1. Select Geometry > Horizontal Curve Set > Stationing.

2. Key in Starting Station: 100+00. (Can be entered as 10000 and then tab out of the field)

3. <D> the Apply button.

4. Verify your results using both of these methods:

♦ Geometry > Review Horizontal
♦ Tools > Tracking > Horizontal Alignments
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5. Select Geometry > View Geometry > Stationing.

6. <D> the Preferences button.

7. <D> the saved preference name Proposed-100 Ft Interval.

8. <D> Load and Close.
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9. <D> the Apply button from the View Stationing dialog.  Stationing is displayed.

10. Experiment with changing the global scale factor value for text and redisplaying the 
stationing.

Lab 5.6 - Annotating an Alignment

Section Objectives:

Understand the difference between Named and Unnamed cogo points and how to apply cogo 
point names.

♦ Learn how to annotate an alignment.
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1. Select Geometry > View Geometry > Horizontal Annotation.

2. Verify the settings as shown above and click Apply to display alignment information.



Colorado Department of Transportation   Page 119

Labs for ROW Geometry & Plans LAB 5 - Horizontal Alignments

3. Review the results in MicroStation.

Challenge Exercise:

1. Use Geometry>Copy Geometry to copy alignment Design ALT 1 to a new 
horizontal alignment named Design ALT 1 Modified.

2. Perform the following actions to the copied alignment:

♦ Move an alignment PI

♦ Redefine one or more horizontal curves

♦ Define alignment stationing as ending at station 382+00

♦ Redisplay stationing at a 500 foot interval

♦ Introduce 2 station equations; one overlap and one gap.

♦ Revert the alignment to a simple PI at point B (remove the curve definition)

♦ Transpose the direction of the alignment

♦ Create a profile showing the existing ground profile along the copied alignment with a 
2x vertical exaggeration

Lab 5.7 - Horizontal Alignment from Graphics

Section Objectives:

♦ Learn how to create a new horizontal alignment from MicroStation graphics.

Alignments can be created from existing MicroStation graphics. In this exercise a chained 
MicroStation element will be used to create an alignment.

1. From the MicroStation pull-down menu select Utilities > Saved Views.
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2. From the Saved Views dialog <D> saved view name Holder Driveway.

3. <D> the Apply button.

4. Select File > Import > Geometry.  The Import Geometry dialog will open.
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Horizontal Alignments, Horizontal and Vertical Alignments, Cogo Points or Event Points 
can be imported from MicroStation graphics. If the alignment has curves, it is 
recommended to toggle on Resolve Gaps and Nontangencies. If the alignment was 
drawn as a series of lines and/or arcs that have not been chained together as complex 
elements toggle on All Selected Elements Added to Single Alignment (you must 
define a Fence or Selection Set of the elements).

After specifying the Name, the Description and the Style, choose Apply. If you 
created a Selection Set or defined a fence prior to initializing the command, you will be 
asked to Accept the contents. If this was not done, you’ll be asked to identify the element. 
In either case, after accepting, an alignment or alignments will be added to the geometry 
project specified in the Target section.

5. Fill in the following information on the From Graphics tab:

♦ Type: Horizontal Alignment
♦ Name: Holder Driveway
♦ Description: Driveway at Sta 190+80 RT
♦ Style: ALG_SECONDARY
♦ Geometry Project: 1234_Geometry Training

6. <D> the Apply button.  The Import Geometry dialog will minimize allowing you to 
see more of your MicroStation view.
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7. When prompted to Identify Element <D> on the MicroStation graphic drawn in the center 
of the driveway.

8. <D> again to accept the highlighted graphics in the MicroStation view.

9. <R> in the MicroStation view to terminate the command.  The Import Geometry dialog 
will restore.  The MicroStation graphics have been imported as an alignment.

Note: The geometry name field increments for additional selection(s).

10. <D> the Close button to close the Import Geometry dialog.

11. Verify the alignment was created.

12. Review the alignment using Geometry > Review Horizontal.

13. When finished Close the dialog box.

14. Time permitting, display the alignment graphics, stationing, and curve information.
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Lab 5.8 - Extend Alignment

Section Objectives:

♦ Learn one of the tools used to modify existing alignments.

The alignment Holder Driveway does not intersect the reference line alignment Design Alt 1.  
Standard practice necessitates the driveway alignment to commence at the main-line reference 
line.

1. Select Geometry > Utilities > and hold.

Note: If the commands for Trim and Extend Alignment are not listed in the menu, this 
means that they are not enabled.  These 2 commands are an extension of the 
Horizontal & Vertical Elements command set which must be enabled.

2. Select Tools > Application ADD-Ins.
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3. Enable Horizontal and Vertical Elements Add-In.

4. Once enabled, Select Geometry > Utilities > Extend Alignment.

5. At the prompt: Identify Alignment to extend to, <D> on the alignment Design Alt 1.

6. At the prompt: Identify Alignment to extend, <D> on the alignment Holder Driveway.

7. <D> to accept the presented solution.
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Note: The alignment-alignment intersection is now the initial point of the driveway 
alignment. Because the alignment was edited (extended) from its beginning, the 
initial station value was recalculated and is assigned a station value of -0+12.41. 
The negative value is due to the original points in the alignment retaining their 
assigned station locations.

8. From the pull-down menu Geometry > Horizontal Curve Set > Stationing define the 
driveway beginning station as 3+25.

Challenge Exercises:

♦ Display stationing at a 100 foot interval for Holder Drive.

♦ Display alignment annotation for Holder Drive.

♦ Recall saved view Drive @ 180+00.

♦ Import the graphics representing the driveway centerline into an alignment named 
Drive 180+00.

♦ Use the command Geometry > Utilities > Trim Alignment to remove the portion 
of the driveway alignment that lies north of the main-line reference line.

Note: The order selecting alignments is not important when using the trim alignment 
command and are prompted to select alignments.  However, the location of the 
data point in response to Identify portion to clip will determine both the alignment 
and the portion that will be eliminated.

Lab 5.9 - Saving Geometry

Section Objectives:

♦ Understand the importance of frequently saving InRoads design data.

Alignments cannot be saved individually. They are saved when the geometry project is saved.  
Due to the fact InRoads works on geometry that is loaded in memory, the geometry project 
must be saved at appropriate times.

Geometry projects can be saved using several methods including:

1. From the pull-down File > Save > Geometry Project.  The Save As dialog will appear 
with the Save as type: set to Geometry (*.alg).

2. Verify you are in the correct project directory C:\Projects\12345\Design\InRoads.
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Note: If the geometry project is already saved, then perform a Save operation instead of 
a Save As (see below).

3. The file name should match the Active: name at the bottom of the Save As dialog.  If 
necessary, use the drop-down arrow in the Active: field and reselect the desired name to 
ensure the saved file name will match the surface name.

Note: Geometry projects have both an internal name that appears in the dialog boxes in 
InRoads and a name on the hard drive that has an .ALG extension. To minimize 
any confusion between these two names, ensure that the saved Geometry name in 
the project folder matches the Geometry name displayed in InRoads explorer.

4. <D> the Save button and then the Cancel button.  The file will be saved to disk and the 
Save As dialog will close.
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Lab 5.10 - Creating Parallel Horizontal Alignments

Section Objectives:

♦ Learn additional tools for creating alignments.

Offset alignments can be created to generate geometry for elements such as right-of-way limits, 
easement limits, under-drains, retaining walls, bridge decks, etc.

In this lab we will generate right-of-way limits for the mainline road and the side road. The 
Side Road has a right-of-way width of 60’ (30’ on each side of centerline).  The mainline 
alignment has a total right-of-way width of 150’ being 50’ feet north of the reference line and 
100’ south. At the intersection of the right-of-way lines a radius of 15’ is required.

The workflow will consist of using an assortment of geometry commands:

♦ Copying Geometry - used to combine geometry residing in two different geometry 
projects into one project

♦ Multi-Center Curve – to create radius returns

♦ Parallel Horizontal Alignment -  to offset alignments

♦ Join Alignments – to connect separate alignments

♦ Join Elements – to simplify geometry
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The first step is to create alignments relative to both the mainline alignment (SH 86) and the 
side road alignment (Side Road). These two horizontal alignments reside in two different 
geometry projects. To work efficiently, they should reside in a single geometry project. The 
Copy Geometry command is used to achieve this result.

1. Select Geometry>Copy Geometry.
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2. Copy the alignment Side Road from geometry project 12345_Design to the geometry 
project 12345_Geometry Training.

Note: Also copy alignment SH 86 as SH 86 ALT 1 if you feel the mainline alignment 
created by an earlier lab exercise may be problematic.

3. Verify the alignment was copied.

4. Set the geometry project 12345_Geometry Training as Active causing newly created 
geometry to populate this project.

The next step is to generate the radius returns.  This is done by using the Multi-Center Curves 
command.  Begin by creating the radius returns north of the mainline alignment.

5. From the Saved Views dialog <D> saved view name Side Road.

6. Click Apply.
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7. Select Geometry > Utilities > MultiCenter Curve.

8. Choose One Center.

9. Input the following values:

♦ Width 1: 30
♦ Width 2: 50
♦ Radius: 15

10. <D> the Apply button.  Follow the prompts.

11. In the MicroStation view <D> on the Side Road alignment.

12. <D> on the SH 86 alignment.

13. <D> in the Northwest quadrant

14. <D> to accept and create an alignment representing the radius return.

15. Repeat steps 7-12 and <D> in the Northeast quadrant.



Colorado Department of Transportation   Page 131

Labs for ROW Geometry & Plans LAB 5 - Horizontal Alignments

New alignments will be assigned names based on the seed alignment name specified in 
Tools > Options [Geometry].
Two new alignments are created, 1and 2.

Note: Your stationing graphics may appear at a different location than shown above.

The next steps will be to offset the mainline and side road alignments so they match up with the 
returns that were just created.  This is done using the Offset Alignments by Station command.
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16. From the MicroStation pull-down menu, select Utilities > Keyin. The key in browser is 
needed to input the desired station limits and offset distances. Without this, they could be 
defined graphically.

17. From the InRoads pull-down menu Geometry > Utilities > Parallel Horizontal 
Alignment....

18. In the Parallel Horizontal Alignment dialog box toggle on Interactive By Station and 
then click Apply.

19. In the MicroStation view <D> on the mainline alignment.

20. At the prompt Identify First Station/Key in Station, key in 224+00.

21. <D> the Run button or press the Enter key.

22. At the prompt Identify Second Station/Key in Station, key in 224+93.20.

23. <D> the Run button.

24. For Identify Location: key in -50 (50’ to the left).

25.  <D> the in the view window to accept the solution and alignment 3 is created and 
displayed.
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26. Repeat the Geometry > Utilities > Parallel Horizontal by Station command to the 
east of the sideroad using the following data:

♦ Station limits of: 225+86.76 to 227+00, 50’ left of US 86 Alt 1

Note: The station limits can be graphically selected by issuing a data <D> point in the 
MicroStation view. The offset distance can also be graphically selected but using 
the key in field allows a specific distance to be input.

Alignment 4 is created and displayed.

27. Re-execute the command to create the alignments along the Side Road north of the radius 
returns.
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Next we will use the Join Alignment command to connect the alignments created in the 
previous steps single alignments for each quadrant.  This command operates by either 
connecting the components with a straight line segment or by paralleling an alignment to define 
the configuration of the created geometry.

Join alignments 3, 1, & 5 to create the Northwesterly right-of-way limits.

28. Select Geometry > Utilities > Join.

29. Check On Delete Original Alignments. 

Note: The first alignment identified (3) will become the final alignment name and 
alignments (1) and (5) will be deleted upon completion of the command.

30.  <D> the Apply button and follow the prompts.

31. Identify Initial Alignment: <D> on alignment 3.

32. Identify Alignment to Parallel/Skip:  <D> alignment 1 to parallel (overlay) this alignment.

Note: If a reset <R> is issued in the above step, a tangent line would be created from the 
end of alignment 3 to the beginning of alignment 5.  By selecting the alignment 
representing the radius return, a curved section is generated at a zero offset to 
alignment 1.

33. Identify Next Alignment: <D> on alignment 5.

34. Accept or Reject: <D> to accept the dynamic display.
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35. Reset <R> <R> twice to terminate the command.

Alignment 3 is now the combination of the alignments 3, 1, and 5. Alignments 1 and 5 are 
removed from the geometry project.
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36. Review alignment 3.

37. Using the same steps above, join alignments 6, 2, and 4 to create the northeasterly right-of-
way limits; begin with alignment 6.

Once the above step is completed, alignments 3 and 6 define the right-of-way limits on the 
north side of the intersection.

Another method of creating parallel alignments is by element instead of by station.

38. Choose Geometry > Utilities > Parallel Horizontal by Element.
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Parallel by Element differs from by Station in that you can select the limits of the 
alignment to offset by selecting, <D>, alignment components (tangent or curve) to define 
the desired limits.
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