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LAB 27 - Create Raised Median

This lab demonstrates a procedure for modeling a roadway which includes a raised median and a median 
opening.  The exercise below uses a single template which utilizes point controls and display rules to achieve 
the two different roadway sections. Additionally a second template is used to model the median openings.

Chapter Objectives:

 Use a single template to model the mainline with and without a median

 Create display rules which determine when the raised median excluded

 Use point controls to define the location of the median nose

 Model multiple corridors

 Combine corridors in a single final surface

Lab 27.1 - Workflow 

A summary of the overall process

1. In addition to the mainline horizontal and vertical alignments, create horizontal align-
ment(s) for the median nose.

2. Create a template for the crowned roadway - without the raised median.

3. Model the mainline using the crowned template.

4. Create the vertical alignments for the median noses by extracting their elevations from the 
surface created in the previous step.

5. Create a template for the median noses

6. Model the median noses

7. Create a template for the raised median

8. Add Display Rules to the components of the raised median.

9. Create a corridor definition for the raised median

10. Add point controls to constrain the raised median template to run as defined, constrained to 
the medians or to the mainline alignment.

11. Define key stations for template drops.

12. Create the final design surface by modeling the mainline and median openings 
simultaneously.



Page 600 Colorado Department of Transportation

LAB 27 - Create Raised Median Labs for InRoads V8i SS2

Modeling Schematic



Lab 27.2 - Open Lab Files

An initial model of the roadway is crated using the roadway typical section without the median. 
This is done for the purposed of extracting the profile gradeline for the median noses.

1. Open MicroStation and InRoads using the 12345DES_Model-Create Raised Median.dgn 
file.

2. Verify that the file C:\Workspace\Workspace-CDOT_XM\Standards-Global\InRoads\
Preferences\CDOT_Civil.xin

3. Select File> Open from the InRoads menu bar.

4. Open the following files from C:\Projects\12345\Design\InRoads\ folder:

♦ 12345DES_Existing-Create Raised Median.dtm

♦ 12345DES_Geometry-Create Raised Median.alg

♦ 12345DES_Templates-Create Raised Median.itl

♦ 12345DES_Roadweay-Create Raised Median.ird

5. <D> Cancel the Open dialog box to close.

Lab 27.3 - Review The Alignments

In this exercise three alignments are used. Federal CL for the main corridor, Median Nose and 
Median Nose_North which define the median opening and termination.

1. Select the Geometry tab in the InRoads Explorer

2. View the horizontal alignments Federal CL, Median Nose and Median Nose_North 
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3. View stationing for horizontal alignment Federal CL

Lab 27.4 -  Review Data

An initial model of the roadway was created using a crowned roadway section (without the 
raised median). This was done for the purpose of extracting the vertical profile of the median 
noses. This was accomplished by using the command File > Import > Geometry [Vertical 
From Surface]. 

Next, the templates used for the project are reviewed.

1. Select Modeler > Create Template from the InRoads menu bar.
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2. In the Create Template dialog box review the template for Median Nose in the 1-
Templates folder.

3. Also in the Create Template dialog box, review the templates for Federal Blvd. in the 
1-Templates folder. 

The Federal Blvd template was use to create a preliminary model. This model was used to 
extract vertical alignments for the median alignments. 

The template Federal Blvd with Raised Median. uses display rules control to determine 
when the median is modeled.
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The illustration below shows an expanded view of the median. The ‘Laneline’ points will 
be controlled by both the Federal Blvd. and median alignments. Additionally the median 
components will be assigned display rules which will test the distance between the 
lanelines and the PGL.

Lab 27.5 - Add Display Rules

Display rules are associated with components to test if the component should be displayed or 
not. The display rules turn off the median components if the distance between either lanelines 
and the PGL is less than 5.50’. This is the distance from the mainline alignment to the PC or PT 
of either median nose alignment.

1. Copy the template Federal Blvd with Raised Median to Federal Blvd with Raised 
Median_DR.

2. Open the Federal Blvd with Raised Median_DR template for editing.

3. Select the median curb and gutter component named LT_C/G_Type2-1B for editing. In the 
Component Properties dialog box, select the Edit button.
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4. In the Component Display Conditional Expression dialog box, select the Add button.

5. Create a Display Rule that tests the distance between the Left Laneline and the PGL 
using the following data:

♦ Name: LeftC/G
♦ Description: test distance between LT laneline and PGL
♦ Type: Absolute Horizontal
♦ Between: LT_Conc_Laneline-Top1 

♦ And: PGL
♦ Test (button): >=
♦ Value (field): 5.50
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6. Highlight the rule and <D> the Selected Rule button. 

7. <D> OK to use the rule and dismiss the dialog box.

8. In the Component Properties dialog box, <D> Apply then Close.

9. Select the component RT_C/G_Type2-1B for editing.

10. Build and apply a similar rule for the RT Laneline using the following data:

♦ Name: RightC/G
♦ Between: RT_Conc_Laneline-Top1 

♦ And: PGL
♦ All other fields are the same

11. Edit the component CONC_Sidewalk-4” 

12. Build and Apply a Display Rule to test for a minimum distance of 11.00 feet between the 
RT and LT Lanelines for the Median Cover (Conc_Sidewalk-4”) using the following data:

♦ Name: MedianPavt
♦ Description: Test width between lanelines
♦ Type: Absolute Horizontal
♦ Between: LT_Conc_Laneline-Top1 

♦ And: RT_Conc_Laneline-Top1
♦ Test (button): >=
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♦ Value: 11.00

13. Save and Close the Create Template dialog box.

Lab 27.6 - Create Corridors

Corridors contain definitions for which alignments, templates, point controls, etc. are used to 
model the roadway.   In this exercise, three corridors are defined, one for each median nose and 
a new one for the mainline. 

1. Select Modeler > Roadway Designer

2. Select Corridor > Corridor Management from the Roadway Designer menu bar.

3. In the Manage Corridors dialog box, key in Median Nose for the Name.

4. Set the Type to Alignment.

5. Set the Horizontal Alignment to Median Nose.

6. Set the Vertical Alignment to Median NoseV.

7. <D> the Add button to create the corridor.

8. Repeat the steps above to add a corridor for the Median Nose_North alignment using the 
following data:

♦ Name: Median Nose_North
♦ Type: Alignment
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♦ Horizontal Alignment: Median Nose_North
♦ Vertical Alignment: Median Nose_NorthV

9. Create a corridor for the Mainline using the following data:

♦ Name: Federal_Display_Rule
♦ Type: Alignment
♦ Horizontal Alignment: Federal CL
♦ Vertical Alignment: Federal CL_V
♦ Start Station: 8+00
♦ Stop Station: 19+00

10. <D> Close to dismiss the Manage Corridors dialog box.

Lab 27.7 -  Add Template Drops

Templates define the cross section of the design model. They are assigned to the corridor 
through the Template Drops dialog box. The starting station defaults to the beginning of the 
corridor, so setting the interval and selecting the desired template is all of the input that is 
required.

1. Select Corridor > Template Drops from the Roadway Designer menu bar.

2. Highlight the Median Nose template from the Library Templates list.

3. Key in 1 for the Interval.

4. <D> Add to create the template drop.

Next, add a template drop to the Median Nose_North corridor.
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5. Set the Corridor to Median Nose_North.

6. Highlight the Median Nose template from the Library Templates list.

7. Key in 1 for the Interval.

8. <D> Add.

9. Set the Corridor to Federal_Display_Rule.

10. Key in 8+00 for the Station.

11. Key in 10 for the Interval.

12. Highlight the Federal Blvd with Raised Median_DR template from the Library 
Templates list.

13. <D> Add then Close to dismiss the Template Drops dialog box.

Use Roadway Designer to evaluate the corridors. The template data is displayed in the cross 
section view of the Roadway Designer dialog box. There are two options for scrolling through 
the corridor; using the station arrows below the cross section view and using the station line in 
the plan view.
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14. In the Roadway Designer dialog box, set the Corridor to Median Nose.

15. <D> on the station arrows to scroll through the design. Notice how the data in the cross 
section view is updated for each station.

16. <D> and Hold on the yellow station line. Move the pointer back and forth to scroll 
through the design. The data is now updated based upon the location of the station bar.
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17. Evaluate the Federal_Display_Rule corridor.

Lab 27.8 - Change Roadway Designer Settings

The Roadway Designer settings determine if additional stations are processed, what information is displayed in 
the views, and what information is included in the processing report. In this exercise, cardinal points are 
processed and component and point information is added to the processing report.

The first series of steps set Roadway Designer to process the horizontal cardinal and event points. 

1. From the Roadway Designer menu bar, select Tools > Options.

2. In the Roadway Designer Options dialog box, toggle on the following options: 

♦ Horizontal Cardinal Points
♦ Vertical Cardinal Points
♦ External Control Points
♦ Reference Graphics
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♦ Transition Graphics.

3. <D> OK.

4. Scroll through the stations and notice that some stations do not fall on even intervals.  
These are the cardinal and event points.
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Lab 27.9 - Point Controls

This series of steps adds Point Controls (overrides) to the Federal_Display_Rule corridor. The 
roadway is modeled as defined until it encounters a point control. For this design, three point 
controls are required for each side of the roadway (Left laneline and Right laneline) for 6 total 
point controls. The first control instructs the laneline to follow a feature created by the Median 
Nose corridor. The second control instructs the laneline to follow the mainline alignment. The 
third control instructs the laneline to follow a feature created by the Median Nose_North 
corridor.

1. Verify the corridor Federal_Display_Rule is the active corridor.

2. Select Corridor > Point Controls from the Roadway Designer menu bar.

Next, create the following Point Control entries to instruct the RT_Conc_Laneline-Top1 
template point to follow a feature (by the same name) created by the Median Nose corridor.

3. Select RT_Conc_Laneline-Top1 from the Point drop-down menu.

4. Set the Mode to Both. 

5. Set the Control Type to Corridor Point.

6. Select Median Nose for the Corridor.

7. Select Conc_Laneline-Top 1 for the Reference Point.

8. Key in 10+00.00 (begin of median radius) for the Start station.

9. Key in 10+05.50 (end of median radius/nose) for the Stop station.

10. <D> ADD to create the point control.

11. Repeat the steps above to add the other two point controls for this corridor, using the 
following data:

♦ Second point control

○ Point: RT_Conc_Laneline-Top1
○ Mode: Both 

○ Control Type: Alignment
○ Horizontal Alignment: Federal CL
○ Vertical Alignment: Federal CL_V
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○ Start Station: 10+05.51 (end of median radius/nose - beginning of median 
opening)

○ Stop Station: 12+00.00 (beginning of north median/radius nose)

♦ Third point control

○ Point: RT_Conc_Laneline-Top1
○ Mode: Both 

○ Control Type: Corridor Point
○ Corridor: Median Nose_North
○ Reference Point: Conc_Laneline-Top 1
○ Start Station: 12+00.00 (begin of median radius/nose)

○ Stop Station: use the default station.

The fourth, fith, and sixth entry for the LT_Conc_Laneline-Top1 point. The definitions mimic 
the definitions use for the RT_Conc_Laneline-Top1 point.

♦ Fourth point control

○ Point: LT_Conc_Laneline-Top1
○ Mode: Both. 

○ Control Type: Corridor Point
○ Corridor: Median Nose for the Corridor.

○ Reference Point: Conc_Laneline-Top 1 for the Reference Point.

○ Start Station: 10+00.00 (begin of median radius) 

○ Stop Station: 10+05.50 (end of median radius/nose) 

♦ Fifth point control

○ Point: LT_Conc_Laneline-Top1
○ Mode: Both 

○ Control Type: Alignment
○ Horizontal Alignment: Federal CL
○ Vertical Alignment: Federal CL_V
○ Start Station: 10+05.51 (end of median radius/nose - beginning of median 

opening)

○ Stop Station: 12+00.00 (beginning of north median/radius nose)
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♦ Sixth point control

○ Point: LT_Conc_Laneline-Top1
○ Mode: Both 

○ Control Type: Corridor Point
○ Corridor: Median Nose_North
○ Reference Point: Conc_Laneline-Top 1
○ Start Station: 12+00.00 (begin of median radius/nose)

○ Stop Station: use the default station.

12. <D> Close to dismiss the Point Controls dialog box.

13. Review the results graphically in Roadway Designer. Notice that the raised median 
disappears between stations 10+00.00 and 10+05.00 and again between 12+00.00 and 
12+05.00. Between these station extents, the corridors for the medians will complete the 
model.

Also notice that the left and right pavement edges run together between stations 10+05.51 
and 12+00.00. This represents the median opening.
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Lab 27.10 - Adding Key Stations

Key Stations are specific locations you define relative to your design.  At these locations an 
additional template is processed. You can also elect to create a cross section a locations defined 
by key stations. Examples of Key Stations may be at driveways, side roads, drainage structures 
or in the case of this exercise, just prior to and after the application of point controls. This 
ensures that the roadway is modeled as designed and eliminates transitions between point 
controls and the next corridor defined interval.

1. Select Corridor > Key Stations from the Roadway Designer menu bar or <D> the Key 

Station button .

2. Key-in the station values as shown in the list below. Select Add after each entry.

♦ 9+99.99

♦ 10+05.51

♦ 11+99.99

♦ 12+05.51

3. <D> Close

4. Select File > Save from the Roadway Designer menu.

Lab 27.11 - Creating the Model

With all the corridors, template drops point controls and key stations defined, the model is 
ready to be created.

1. Select Corridor > Create Surface from the Roadway Designer menu bar or <D> the 

Create Surface button 

2. Select the following corridors for modeling:

♦ Federal_Display_Rule

♦ Median Nose

♦ Median Nose_North
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3. <D> on the Clipping Options button.

4. Under the Clipping Option column, <D> to cycle through the options and set both the 
Median Nose and Median Nose_North corridors to Clip None.
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Also set:

♦ Name: Design Model
♦ Default Preference: Proposed

And toggle on:

♦ Densify Horizontal Curves using Chord Height Tolerance
♦ Densify Vertical Curves using Chord Height Tolerance
♦ Triangulate
♦ Remove Loops
♦ Display Features in Plan View

And toggle off:

♦ Add Exterior Boundary - Style:

Lab 27.12 - Review the Design

Use your knowledge of InRoads to review your model. 

Some methods may include:
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 A 3D isometric view of DTM features

 DTM triangles

Contours, profiles and cross sections are additional options.

Chapter Summary:

 Display Rules are used to turn on or off components based on the relationship between two 
points

 Point Controls are used to modify a template during processing. In this lab, the point 
controls were used to modify the relationship between points used in display rules to affect 
the display co the median components

 Key Stations and the settings under Options force the template to be processed at specific 
stations in addition to the processing that occurs at the normal template drop interval

 Clipping Options determine how template components are affected in areas where 
corridors overlap. The None option was used here, so that all of the components from each 
corridor would be retained.
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