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LAB 28 - Create Ramp Model

This lab demonstrates the InRoads design process for creating a single lane freeway entrance ramp (tapered 
type) model and the infield, gore and taper area segment of the mainline model. The Vertical Gore Tool is used 
to create a guide for revise and tie the ramp vertical alignment into the edge of lane of the mainline taper. The 
corridors are created for both the ramp and mainline models. Display rules, Point controls, and end condition 
exceptions are used to tie the inside of the ramp model into the mainline corridor model in the gore and infield 
area. The outside lane of the mainline corridor is widened with a point control to create the ramp taper. After 
the ramp and mainline surfaces are created from the Roadway Designer, cross sections are displayed and 
examined to view the results.

Chapter Objectives:

 Revise the ramp vertical alignment to tie into the edge of lane of the mainline taper using 
the Vertical Gore Tool

 Create the freeway entrance ramp (tapered type) model 

 Create the infield, gore and taper area segment of the mainline model

 Create a ramp and mainline surfaces from Roadway Designer, display cross sections and 
examine the results

The following files are used for this lab:

 C:\Projects\12345\Design\InRoads\12345DES_Geometry-Create Ramp Model.alg

 C:\Projects\12345\Design\InRoads\12345DES_Template-Create Ramp Model.itl

 C:\Projects\12345\Design\InRoads\12345DES_Roadway-Create Ramp Model.ird

 C:\Projects\12345\Design\InRoads\12345DES_Existing-Create Ramp Model.dtm

 C:\Projects\12345\Design\InRoads\CDOT_Civil-Create Ramp Model.xin

Lab 28.1 -  Open InRoads Data Files

1. Open MicroStation and InRoads using the 12345DES_Model-Create Ramp Model.dgn 
file.

2. Load CDOT_Civil-Create Ramp Model.xin.

In the MicroStation drawing, notice the entrance ramp and mainline proposed linework 
displayed as a reference and the profile views for each alignment.

3. Open the following files from the C:\Projects\12345\Design\InRoads\ directory in 
InRoads:

♦ 12345DES_Geometry-Create Ramp Model.alg

♦ 12345DES_Template-Create Ramp Model.itl

♦ 12345DES_Roadway-Create Ramp Model.ird

♦ 12345DES_Existing-Create Ramp Model.dtm

Lab 28.2 - Set the Global Scale Factors

1. Select Tools> Options from the InRoads menu bar.
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2. In the Options dialog box, Select Factors tab.

3. Key in 200 for the Text and Cell Scale Factor fields.

4. <D> Apply and <D> Close.

Lab 28.3 - Create Ramp Vertical Alignment Guide with Vertical 
Gore Tool

The Vertical Gore Tool is used to create a guide for revising the ramp vertical alignment. The 
output from this command is a surface with four linear features which are then displayed in the 
profile of the ramp alignment. These features specify the allowable maximum and minimum 
elevations of the ramp vertical alignment, as well as the ideal locations to make the gore cross 
slope match the mainline and ramp cross slopes. 

The exercise will use the Mainline Ideal cross slope to set the ramp’s vertical alignment. This is 
used because the mainline’s cross slope extends out at a constant 2% from the crown in the 50:1 
taper section. Note the Ramp Ideal cross slope feature is at the same location.

1. Select Modeler> Roadway Designer from the InRoads menu bar.

2. Select Tools> Vertical Gore Tool from the Roadway Designer menu bar.

3. In the Vertical Gore Design Tool dialog box, select IH 39 in the Mainline Corridor field.
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4. Select LT_Outside_Conc_EOP-Top for the Mainlined Edge field, using the drop-down 
list or the selector button.

5. Select NW Ramp in the Ramp Corridor field.

6. Select IN_Conc_EOP-Top for the Ramp Inside Edge field.

7. Select OUT_Conc_EOP-Top for the Ramp Outside Edge field.

8. Key in 8% in the Maximum Difference field.

9. Key in 30+50 in the Mainline Start field.

10. Key in 32+00 in the Mainline Stop field.

11. Key in Gore Design in the Surface Name field.

12. Select D_GORE_Max_Vertical for the Maximum Style.

13. Select D_GORE_Mainline_Ideal for the Mainline Ideal Style.

14. Select D_GORE_Ramp_Ideal for the Ramp Ideal Style.
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15. Select D_GORE_Min_Vertical for the Minimum Style.

16. <D> Apply and <D> Close to dismiss the Vertical Gore Design Tool dialog box.

17. In the Roadway Designer dialog box, <D> Close and select No to save changes.

Lab 28.4 - Update NW Ramp profile and Modify the Vertical 
Alignment

1. Select Evaluation> Profile> Update Profile from the InRoads menu bar.

2. In the Update Profile dialog box, verify that NW Ramp is selected for the Profile Set.

3. Select Projected Features from the Update Profile tree.

4. Select Display On for the Mode.

5. Select Gore Design in the Surfaces area.

6. Select All features in the Projected Features area.
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♦ <D> Apply and <D> Close.

The NW Ramp vertical alignment needs to be revised to tie to the edge of lane of the 
mainline taper and to better tie into the mainline ditch in the infield area.

7. Set alignment NW Ramp as the Active alignment

8. Select Geometry> Vertical Curve Set> Move PI from the InRoads menu bar.

9. <D> Apply on the Move Vertical PI dialog box then <D> on the first vertical PI.

10. In the MicroStation key in window, type se=31+38.43,5268.54 and press Enter.

11. <D> to accept the location then <R> to exit the command.

12. <D> Apply on the Move Vertical PI dialog box then <D> on the second vertical PI.

13. In the MicroStation key in window, type se=35+75.00,5251.04 and press Enter.

14. <D> to accept the location then <R> to exit the command.

15. <D> Close to dismiss the Move Vertical PI dialog box.

16. Select Geometry> View Geometry> Vertical Annotation from the InRoads menu 
bar.

17. <D> Apply and <D> Close.

18. Examine the changes in the vertical alignment.

Next, revise NW Ramp corridor to start at the beginning of the ramp’s revised vertical 
alignment.

19. Select Modeler> Roadway Designer from the InRoads menu bar.

20. In the Roadway Designer dialog box, select NW Ramp from the Corridor drop down 
menu.
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21. Select Corridor > Corridor Management from the Roadway Designer menu bar.

22. Highlight NW Ramp in the Corridors area. 

23. Key in 31+38.43 in the Start field.

24. <D> Change.

25. <D> Close to dismiss the Manage Corridors dialog box.

Lab 28.5 - Define End Condition Exceptions 

1. In the Roadway Designer dialog box, select IH 39 from the Corridor drop down menu.

2. Select Corridor> End Condition Exceptions from the Roadway designer menu bar.

3. Key in 31+38.43 in the Start field.

4. Key in 40+50 in the Stop field.

5. Toggle on Left Override in the Apply To area.

6. Toggle on Backbone Only

7. <D> Add and <D> Close to dismiss the End Condition Exceptions dialog box.

Next, end condition exceptions are added to right side of NW Ramp along the gore and infield 
area.

8. In the Roadway Designer dialog box, select NW Ramp from the Corridor drop down 
menu.

9. Select Corridor> End Condition Exceptions in the Roadway designer menu bar.

10. Key in 31+38.43 in the Start field.

11. Key in 40+50 in the Stop field.

12. Toggle on Right Override in the Apply To area.

13. Toggle on Backbone Only.

14. <D> Add and <D> Close to dismiss the End Condition Exceptions dialog box.

Lab 28.6 - Define Point Controls 

Define Point Controls for the IH 39 corridor. Stretch westbound roadway’s left edge of 
pavement to create the ramp taper.

1. In the Roadway Designer dialog box, select IH 39 from the Corridor drop down menu.

2. Select Corridor> Point Controls in the Roadway designer menu bar.
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3. In the Point Controls dialog box, select LT_Outside_Conc_EOP-Top for the Point.

 

4. Toggle on Horizontal for the Mode.

5. Select Alignment in the Control Type field.

6. Select Outside Edge of Pavement in the Horizontal Alignment field.

7. Toggle on Use as a Secondary Alignment.

8. Key in 31+38.43 in the Stop Station field.

9. <D> Add and <D> Close to dismiss the Point Controls dialog box.

Create a special ditch between the ramp and mainline shoulder pavements from the gore nose 
to a station where the mainline ditch starts (when the ramp fore slope is flatter than the 3:1 
maximum).

1. In the Roadway Designer dialog box, select NW Ramp from the Corridor field.

2. Select Corridor> Point Controls in the Roadway designer menu bar.
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3. In the Point Controls dialog box, select IN_Gore_Ditch from the Point menu.

4. Toggle on Both for the Mode.

5. Select Alignment in the Control Type field.

6. Select Special_Ditch_NW_Ramp in the Horizontal Alignment field.

7. Toggle off Use as a Secondary Alignment.

8. Key in 31+38.43 in the Start Station field.

9. Key in 35+99.90 in the Stop Station field.

10. <D> Add

11. Select IN_POSS from the Point menu. 
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12. Toggle on Both for the Mode.

13. Select Corridor Point in the Control Type field.

14. Select IH 39 in the Corridor field.

15. Select LT_Outside_Conc_EOP-Top in the Reference Point field. 

16. Key in 31+38.43 in the Start Station field.

17. Key in 35+99.90 in the Stop Station field.

18. <D> Add

19. Select IN_Toe-Point-Control from the Point menu. 

Note: This component has a display rule.

20. Toggle on Both for the Mode.

21. Select Corridor Point in the Control Type field.

22. Select IH 39 in the Corridor field.

23. Select LT_POSS in the Reference Point field. 

24. Key in 36+00 in the Start Station field.

25. Key in 40+50 in the Stop Station field.

26. <D> Add and <D> Close to dismiss the Point Controls dialog box.

Lab 28.7 - Define Key station for IH 39 corridor

1. Select IH 39 from the Corridor drop down menu.

2. Select Corridor> Key Stations in the Roadway designer menu bar.

3. Key in 31+38.42 in the Station field.
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4. <D> Add and <D> Close

Next, define Key station for NW Ramp corridor.

5. In the Roadway Designer dialog box, select NW Ramp from the Corridor drop down 
menu.

6. Select Corridor> Key Stations in the Roadway designer menu bar.

7. Key in 3599.90 in the Station field.

8. <D> Add and <D> Close.

Lab 28.8 - Create Surfaces to display in cross sections to 
examine design models

1. In the Roadway Designer dialog box, select Existing_Ground from the Active Surface 
drop down menu.

2. Select Corridor> Create Surface in the Roadway designer menu bar.

3. Select the following options as shown in the illustration below: 

4. <D> Apply to create the surface.

5. Review and then close the Results dialog box. 

6. <D> Close to dismiss the Create Surface dialog box.
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7. In the Roadway Designer dialog box, select File> Save from the Roadway designer menu 
bar.

8. <D> Close to dismiss the Roadway Designer dialog box.

Lab 28.9 - Display and Review Cross Sections

9. Make IH 39 the active alignment.

10. Select Evaluation> Cross Section> Create Cross Sections from the InRoads menu 
bar.

11. In the Create Cross Section dialog box, <D> Preferences.

12. Highlight 40H 20V 320’ Wide.

13. <D> Load then Close.

14. Toggle off Gore surface.

15. <D> Apply and <D> in the drawing view to display the cross section set.

16. <D> Close to dismiss the Create Cross Section dialog box.

17. Select Evaluation> Cross Section> Cross section Viewer from the InRoads menu 
bar.

18. Select 24+00.00 in the Cross Sections area and <D> Run.

19. Examine the ramp and westbound mainline sections as the viewer moves along the taper, 
gore, and infield areas.
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Chapter Summary:

 The Vertical Gore Tool is used to create design guides for laying out vertical alignments on 
merging corridors

 End Condition Exceptions are used to modify or remove the sideslope within a defined 
station range

 A single design surface can be created from two or more corridors
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